How can we Help?

Installing Callbar App on Linux Cent OS 7-1708


Note: This knowledge base article is currently a work in progress, as our Engineering team is still working on delivering the official package for RPM Linux distributions.


RPM Linux Package installation (CentOS)



To have Callbar App working on Linux CentOs 7-1708 with 64 bit platform, some dependencies must be installed first.



  • EPEL-Release (info)
  • libappindicator (info)
  • libXSrcnSaver (info, this dependency is needed after the Linux OS updates)


Note: Without the above dependencies installed you will get the following error:

error: failed dependencies:
      libappindicator is needed by Callbar-[VERSION]


Installing Dependencies:

These install instructions are using ‘yum’ as it is the primary tool for getting, installing, deleting, querying and managing Linux RPM. If your system is using a different tool you don’t need to install yum:

 sudo yum install epel-release
 sudo yum install libappindicator
 sudo yum install libXScrnSaver

Installing Callbar:


sudo rpm -i Callbar-[VERSION].rpm


Uninstalling Callbar:

rpm -e Callbar


Using Callbar App with Talkdesk ID:  

As we are currently in the process of rolling out Talkdesk ID, in all distributions of Linux it is yet only supported through Chrome browser. In order to use it, you’ll need to have Chrome installed.

If you have any problems installing Chrome on your machine please follow this link.


Callbar App Production Installation Files:

Have more questions? Submit a request


Powered by Zendesk